The best place for all your technical questions

Unable to have the full speed of my internet

Reply
Chevalier

Unable to have the full speed of my internet

Hi,

 

I have the 120 hybride Fiber, but I'm not able to obtain that speed... 

I'm using both 2,4 and 5 GigHz band.

 

anyone can help me?

3 REPLIES 3
Chevalier

Re: Unable to have the full speed of my internet

Basically, you've got 4 possible causes for this slow-down.

 

  1. Your cable connection.
  2. Your router
  3. Your wifi connection (either 2.4/5ghz)
  4. Your computer
  5. Your kids (yes, the true culprits)

 

To verify your true & real speed; always check-out videotron's own speedtest tool at http://testvitesse.videotron.ca

 

I'd suggest approaching your problem iteratively with the following steps (from easiest to most-complex) while using the above speedtest service.

  1. Ask everyone to turn-off their devices (literally, powered-off!); and only test with your laptop to see if things improve.
  2. Try another device to rule-out your laptop (just to have a second opinion).
  3. Connect your laptop directly into the router with an ethernet cable; to see if the problem might not be your aging router that just can't handle Videotron's 120mbit of pure speed.
  4. Connect your laptop directly into the cable-modem with an ethernet cable (remember to power-cycle the modem first!), to see if you might need to engage a service technician.

 

Another good read:

https://lifehacker.com/why-is-my-internet-suddenly-so-slow-1525144792

 

But you can also call videotron's tech-support Smiley Wink

Initiate

Re: Unable to have the full speed of my internet

I had the same issue; in my case If your router is compatible (gigabit ready, wireless 802.11n or ac) you can set it to use only «n » or “a/c” mode in Wireless Network Mode and on WPA AES. Also WMM Support should be enabled.

As soon as I set the router to the above settings I was getting much closer to 120 mbps depending on the number of devices connecting on this 5ghz signal.
Initiate

Re: Unable to have the full speed of my internet

I had trouble using my 5ghz signal using ac only (dd wrt firmwarev24sp2) despite being able to connect to it the previous day. Could no longer connect to it with the settings as described in previous post. I finally got best results using setting n/a mixed 80 MHz channel width, extension channel upper/ lower.

 

now consistently getting 120mbps down and 20 or more mbps up.

Latest discussions