The best place for all your technical questions

Devices cannot connect to Helix

Reply

Devices cannot connect to Helix

I have a couple of devices (for example, an LG tablet and a PS Vita) that try to connect to my Helix network but are unable to - and it appears that it's the router that's not allowing the connection. Why would this be? Any suggestions to force the connection?

9 REPLIES 9
MayaP
Moderator - Solution Expert

Hi!

Is the password straight-up refused ?

MayaP
Moderator - Solution Expert

Were you able to get the issue resolved?

The issue is partly resolved... Videotron said I should not split my network (into separate 2.4 & 5ghz networks) so I combined them into one and the devices now connect, except often it says I'm connected but with no Internet?
MayaP
Moderator - Solution Expert

Hi!

Combining both networks ia a bit of a double-edged sword. It's super optimal and recommended if you're using exclusively newer devices, but older devices might have some problems with that. 

Routers sold in the market right now pretty much all combine both networks, by default. 

 

Does the "no internet connection" issue happen on all devices, at the same time ?

No, it only appears to affect a few devices intermittently
CedrikS
Moderator - Solution Expert

In that case, here is what you could do:

 

1- Connect yourself to your HelixFi mobile application.

2- Click on the Network tab.

3- On top of the app, click on the pen

4- You should be able to put a checkmark in Use different names and passwords for 2.4 and 5 GHz WiFi.

5- Name each network differently and put a password too. Do not forget to Apply Changes.

6- You should be able to connect manually to the network of your choice and see if everything is more stable.

 

Have a good day!

EricBuist
Officer

Having the same issue with my Sonos One and Fitbit Versa. An old Android tablet connects successfully on the 2.4GHz band though. I'm searching for a solution since a couple of days, to no avail. Seems the Helix Fi is not widespread enough to get a solution, other than adding a second router with a second wi-fi network, and not using Helix wi-fi (but leaving it on unless you wire the TV terminals).

Hi, both my Sonos One and Fitbit Versa can connect now.

 

For Sonos One, I needed to change the wi-fi settings to connect to a new router. First time I tried this, my wi-fi network wasn't listed, but was detected by my phone and my laptop. Second time, a few days later, my wi-fi network appeared and I was able to link my Sonos One to that network, so it works again.

 

My Fitbit Versa already knew about my wi-fi network but couldn't connect. This was because I mistakenly named my Helix network differently (Eldorado instead of ElDorado). Maybe the difference in case screwed things up as well.

Thanks!! It worked!! ☺️

Latest discussions