Showing results for 
Search instead for 
Did you mean: 

WiFi Calling no longer working

Hey folks,

   So I have a Galaxy S9+ which I bought used, I reflashed the Canadian Image (this is a SM-G965W8 (So a Canadian version)) and forced the VTR CSC to be aapplied. At that moment, the WiFi calling feature was able to be activated and worked great. Recently, I went to the US and used another providers SIM Card. Ever since I returned, the WiFi Calling feature will not reactivate. I sometime can "trick" it into working. It sends me the code, which I enter and then I hit back and the Requesting Services pops up with the WiFi Calling icon up top. If I close all recent apps, it stays on and is able to be used, but eventually dissapears. My wife has the exact same phone with the same OS/CSC and hers works perfectly. My VoLTE works and is active. I contacted Tech Support and they gave me the brushoff as "If it wasn't bought from us, we never guarantee it to work" schpeal, also they said because of my IMEI it never should have worked in the first place. I tried a Network Settings reset to see if that would work, but nothing. I'm pretty bummed about this as I have no service in my basement and 1 bar upstairs and it was a real plus to have working. 


Anyone have any ideas? 


Super utilisateur
Super utilisateur

It's a longshot but do you have any "vpn" style apps runing on the phone?


I had adguard for the longest time and whenever my phone would connect to a wifi, I would have to deactivate adguard top get the wifi calling to work, otherwise it would never work.

I have a private DNS turned on, but so does my wife and hers activated again like a boss. 😕 


I'll give it a try again when I get home, though. Thanks for your suggestion. 🙂