Showing results for 
Search instead for 
Did you mean: 

EMG2926 Port forwarding not working




Simple port forwarding for VNC used to work well. It is easy. But the port forwarding on EMG2926 stopped working. Can't trace it back to any update but it does not work.

canyouseeme shows port is open but VNC will not work. I basicall open TCD-UDP port for 5901, 5902,5903 and redirect to 3 PC port 5900 behind the router. VNC from internet then connect to one of these ports.


That used to work. Seems EMG2926 can't. Firewall disables on the router and everything checked.


Any ideas???




did you get any answer? I have the same problem it used to work but now it doesnt work at all

Moderator - Solution Expert
Moderator - Solution Expert

Hi! Does this persist even after doing a factory reset?

I spent an 1hour and a half with my mom on google meet with screen sharing trying to make it work again... Are you guys pushing updates in the routers?

It worked well for a couple of month. Last time i had to use it was early 2020 or late 2019.

tried disabling the firewall did not work. the setting for the port forwarding is still there, but the ports never opens. Do you have any solution? This is terrible. Covid19  prevents me to go to her home. This is very annoying

Not applicable
Maybe the ip adress of the device you want to acces with your port foward changed


I have verified that all port forwards have stopped working. I am a software engineer and have gone through all the steps to verify the port forward--port 443 is the only port that is allowed to be forwarded right now.

I am about to stop using the service due to this, I suggest you all call videotron and threaten them with the same. This service is completely useless to me without port forwards, so I'll be switching immediately.

I can't open any port, even 443!

Whatever port I try, it says is closed. Called Videotron support and the answer was they can't help me!

Superior service!

I can't have even the 443 open. Any port I try, doesn't open.

Called Videotron Support. The answer was we can't help you with port forwarding!!!

Superior support!