The best place for all your technical questions

Zyxel EMG 2926 not assigning IP addresses through wifi range extender D-Link DAP-1325

Reply
Initiate

Zyxel EMG 2926 not assigning IP addresses through wifi range extender D-Link DAP-1325

Hello,

 

I'm seeking some advice as my Videotron Zyxel EMG 2926 router is not assigning IP addresses through my wifi range extender D-Link DAP-1325. My apologies if it's not clear (et que c'est en anglais.)

 

For the last 6 months or so, I've been using the wifi extender as a repeater so that the wifi signal can reach throughout our home. All devices (extender, mobile devices, and Google Home Mini) were working as expected until the last couple of weeks. This was about the time we connected a new wired device (unrelated?) and starting noticing our wifi-devices cutting out or dropping the internet too frequently. I called Videotron and they did a factory reset of the router to try to solve that issue.

 

However, now the extender doesn't work to assign IP addresses. I called D-link tech support and they walked me through several troubleshooting steps. They concluded that nothing is wrong with the extender, and that the problem is with the router not allowing DHCP to pass through the extender.

 

Here's what I observe in three different scenarios:

  1. When the extender is first setup to connect to wifi using the quick setup steps, other devices can connect to the internet through the extender network only very briefly (less than a minute?), then they have no internet access.
  2. If I assign a static IP to the extender, devices connecting to the extender network are unable to obtain an IP address and have no internet access.
  3. When both the extender and a mobile device are set to a static IP, the mobile device can access the internet through the extender network as expected. One possible solution is just to assign everything a static IP for everything connected to the extender network, but I'm not sure that's possible for the Google Home Mini.

PARTIAL SOLUTION:
https://forum.videotron.com/t5/Internet-et-Telephonie/Imprimante-WIFI-non-detecte-par-mon-ordinateur...
I followed the instructions in this thread, which basically turned the WLAN 2.4GHz into Access Point Mode. Now the devices seem to be able to access the internet through the extender, but only intermittently.

Any suggestions on settings to change in the router to make it assign IP addresses through the extender again and maintain the internet connection? I called Videotron and they said they can't help with router settings as they don't see anything wrong with internet access on my main wifi network.

 

Thanks!

-Marcia

Tags (2)

Latest discussions