Showing results for 
Search instead for 
Did you mean: 

Port Forwarding

Yesterday I tried to ascertain why the pert forwarding I had set up over a year ago had become unstable. I logged into my Helix Modem/Router and went to the Port Forwarding section of the Advanced settings. I added an additional port forward entry but, for some reason,  none of my entries worked. Somehow I found out that from now on I would have to use the website at in order to put in my entries.


To give you a little background, I am a retired computer professional with over 40 years of experience in the field. In all that time I have never come across a setup that was so poorly written. I really don't know why it was necessary to deploy it in the first place since port forwarding has always been something folks did locally on their routers. I have at least three observations to make regarding the performance of this website.


First, the website nor the Helix h/w use name resolution properly. Therefore all the Connected Devices show mainly MAC addresses without their names being resolved so you need to create a table yourself to cross check which MAC address corresponds to which connected device. 


Second, the ability to set up port forwarding locally is now removed so we need to deal exclusively with the website. The actual interface on the website is klunky. The drop-down list of the "Selected the device for this port forward" doesn't even match the one on he Helix equipment. Devices are listed as "Generic Windows PC/Laptop" or "Asus Windows PC/Laptop". If I only had 1 or 2 devices on my home network I could mange to identify them this way. Unfortunately, I have over 20 computers without counting all the virtual systems I have also deployed. Therefore, it is virtually impossible to figure this out. Yes, name resolution is the key!!!


Third, a long time ago I must have brought up a laptop using DHCP, and an IP address ending in ".230" was assigned. I use reserved or fixed IPs at home except for cell phones and the like. The laptop in question was later assigned an IP ending in ".98". For some reason, the website recorded the ".230" address and it won't relinquish it. On the Helix device I modified the entry for the laptop to make sure it ends in ".98" but, lo-and-behold, the website ignores this in favour of the ".230" IP.


Fourth, when I called in to support to see if they could help me it became obvious he could not. I was suggested that maybe I should use the Helix device as a modem only and have an additional router introduced where I could set up port forwarding myself locally.


Furthermore, the website interface is asinine in the way it requires the port information to be entered. Why not copy the same set up that existed in the Helix device before it was demoted?


You are absolutely right rvferro 1.

Added to that, starting about 3 weeks ago, Videotron has blocked port 443 (incomming) without any warning to their customers. I was using SSL port to communicate with my home computer via a gateway. Now, I have to specify a port other than 443. I do understand that Videotron wants to avoid commercial usage of home computers running web sites.

A simple warning would have been polite. I was also told by tech. support that port forwarding was 'allowed' but 'not supported' (whatever that means). The Videotron support site (web) explains how to add port forwarding but there is no mention of port restrictions.

Moderator - Solution Expert
Moderator - Solution Expert

Hi! We verified with our different teams in charge of this and they assure us that there has been no change. The 443 port is not blocked. The entire list of blocked ports is; 
incoming ports; 25,135,161,162,445,1080,135,139,445,4444,53,55,77
outgoing ports; 25,139,445,4444

As for support; we offer technical support on a range of issues with your connection. However, the port configuration is not part of the support we offer. Therefore that means you can do it, but we can't help you with the configuration.

Have a nice day!


I've been trying for over a week to get port forwarding to work to use remote desktop. The port is still closed, does anyone know how to fix this problem?

The port may not be blocked via routing or firewall,  but Helix-fi app will not let you redirect port 443. The result is the same: Port 443 is not usable. Besides, if you try to redirect a restricted port, the target device is immediately declared "offline" and is no longer in the list of devices available for redirection. To restore it to online, you have to delete it ("Forget") and re-create it. Passive/agressive behaviour?

can someone help me setup a port forward? i have a NAS at home that i am trying to setup port forwarding to beable to access it remotely but i can't figure out how to use port forwarding.

I fully agree with you that the HelixFi is a low level not even consumer grade device, especially for the setup.  I just switched from Bell and tried to set up port forwarding on this piece of junk and no way.  Not accessible via a browser and the link only led me to the HelixFi cr-app (it's not good enough to be called an app).  I ended up setting the HelixFi junk in bridge mode and use my own router so that I can actually configure this very basic fundamental feature.  Love the fact that apparently the feature is supported, but cannot be configured and phone support was useless to help set up the feature.  One suggestion was that the cr-app only works if you do not change the address, so I set the address back to that.  This did NOT HELP, I still could not configure the feature.  I always change the default settings on such devices.


I too am a network administrator and have never seen such a piece if junk configuration.  To have browser access is one thing (I prefer CLI), but then to have one section of the web interface disabled and pointing to a cr-app to configure is pathetic.


If I find any other issues, I will definitely consider switching ISP.