The best place for all your technical questions

My smart devices won't connect to helix wifi

Reply
marwane1231
Initiate

My smart devices won't connect to helix wifi

Hello,

 

My smart devices won't connect to helix wifi. I tried everything, from splitting to 2.4ghz to opening port, i contacted the manufacture and they gave some steps but nothing is working. i didn't have this problem with the old router. I just got the helix like a week ago, and the devices I used to use won't connect... I don't know what to do.

 

Thank you

3 REPLIES 3
EricBuist
Officer

Not all devices connect, but some do. I'm not getting the pattern. I thought Helix Fi wasn't supporting the 2.4GHz band, but it does, as some devices can connect on that band. Others just won't detect the wi-fi network, e.g., Fitbit Versa and Sonos One. The manufacturers are clueless and will just suggest to retry, retry, retry, retry again, then RMA the device and retry. They just want us to give up, stop using their devices and reduce their customer base to the lucky owners for this their devices work. This is really bad business model, but that's what I observe, each time I have issues, and I have a lot of them, more and more, to the point I will soon need to completely shut everything down for my mental well-being.

The wi-fi issue is probably because the Helix Fi router is not fully 802.11n compliant, or client devices don't comply and the router is too strict. That reminds me of an issue I had on Mac OS X: a mouse was working well on Windows/Linux, but not detected at all by Mac OS X. The mouse driver on Mac OS X was too strict, rejecting the third-party mouse not fully complying to the standard. Apple will say this will work only with Apple mice for simplicity, but this is not true. There is little we can do as consumers, other than giving up on Helix, replacing the non-working wi-fi devices or adding a second router, with a second wi-fi network, that will just cause issues. Probably it could work if you don't use the Helix wi-fi network at all except for Helix TV terminals (or you wire the TV terminals through Ethernet and disable the Helix wi-fi altogether). I'm not getting why Videotron bundles the router with the modem, this is a really bad idea. They just focus on giving the Internet access; internal network management is up to the customer.

HMatrix
Officer

Hi, I might have a theory on why your devices don't want to connect to Helix 2.4Ghz, I worked many years 10+ on wifi at HP/Aruba network in the firmware, my theory is the Helix 2.4Ghz only support WPA2-AES only (both unicast and multicast traffic require AES encryption), there was an old mode that we call WPA mixed mode, with TKIP (old **blip**py WPA1) and AES (WPA2 new good), the reason that "**blip**py" mixed mode exist is to support old devices that can only either do TKIP or AES for unicast and TKIP for multicast.

I might confuse you here but on the Helix router, you do not have the Mixed mode, it is not configurable.

I have a wifi sniffer and I can confirm that the Helix only supports pure WPA2-AES.

Tag: RSN Information
Tag Number: RSN Information (48)
Tag length: 20
RSN Version: 1
Group Cipher Suite: 00-0f-ac (Ieee8021) AES (CCM)
Pairwise Cipher Suite Count: 1
Pairwise Cipher Suite List 00-0f-ac (Ieee8021) AES (CCM)
Auth Key Management (AKM) Suite Count: 1
Auth Key Management (AKM) List 00-0f-ac (Ieee8021) PSK
RSN Capabilities: 0x0000

 

I know this sound very technical if you don`t work in the field, so my suggestion for you is to get an old router that still support Mixed-mode in the configuration of wifi security to have the old device work.

I spent years troubleshooting wifi and sometime you need to dig down to the wifi trace capture to see why the devices cannot connect.

But I can understand why Helix does not support the old Mix Mode, because of newer security concern TKIP is less secure than AES and some certification like Wifi-Alliance kind of make mandatory AES.

I totally understand your frustration, if you need more help just ping me on the forum.

Just check the Helix router, you can only either have Wifi security with AES or No-Security 8-( yike.

For sure they remove WEP which is like no-security 8-)

Latest discussions