Showing results for 
Search instead for 
Did you mean: 

Cannot connect Alexa Echo Dot to Helix network


Here's hoping someone came across this issue and has a solution.


I recently became a Videotron customer.  We recently acquired an Echo Dot, 3rd generation and are in the process of making our home smart.  Initially, all went well. We installed the dot and our smart light bulbs, no problem. At one point, we noticed that the network was a bit weaker in some areas of the house and got a pod to strengthen it.  This meant the pod forced our initially split 2.4 and 5.0 networks to merge, disconnecting the Echo dot (which was onto the 5.0) from the network in the process.


Since, we have tried the following:

- disabling the 5.0 in the admin page and resetting everything ;

- ordering a new Echo dot and trying to install it ;

- reducing security temporarily ;

- enabling network access on the mobile device on which the Alexa app is installed ; 

- uninstalling the Alexa App and re-installing ;

- resetting Echo devices ;

- resetting the Helix ;

- involved Videotron customer service (twice - the Echo dot remains disconnected) ;

- involved Amazon customer service (their response was to replace the device, which did not fix the issue).


What are we missing? We've tried everything and this device still won't connect! Is there anything else we need to try?






Figured it out. Nobody was able to tell us, but google-fu saved us.  

If you have this problem, use this link: IN FIREFOX or SAFARI (no other browser will work) and go to the old version of the website. Do the thing with your computer, and ta da! Problem solved.

Curious as to what you were initially trying to do? Just connect to the network for wifi? Was hopeful you had an answer to making  Alexa work with helix tv go change the channels (like I currently can with the older version of videotron cable)