Le bon endroit pour vos questions techniques

Helix en mode bridge - service télé

Répondre
jgauthier
Disciple

Helix en mode bridge - service télé

Bonjour,

 

Je suis configuré en mode Bridge avec Helix. J'ai mon propre routeur/firewall (pfSense).

L'application Helix TV ainsi que le terminal semblent appeler un très grand nombre d'adresses pour afficher les différents menus. Je peux voir des adresses d'Amazon Web Services (aws) et nombreuses chez COMCAST. Le problème est qu'à moins de laisser tout ouvert dans mon firewall, les menus n'affichent souvent pas de vignettes. Étrangement, certaines passent, d'autres non (voir pièce jointe): helix.jpg

 

Est-ce qu'il serait possible d'avoir les "range" d'adresses complets utilisés par Helix, afin que je puisse configurer toutes les adresses dans mon firewall?

 

Jusqu'à maintenant, c'est le seul problème que je rencontre avec Helix en mode bridge.

 

merci,

 

 

1 RÉPONSE 1
jgauthier
Disciple

Voici les développements depuis mon dernier "post" :

 

Ces problèmes de vignettes qui s'affichent, puis ne s'affichent plus (sans aucun changement effectué sur le routeur) ont étés un véritable casse-tête. Le problème est autant présent via le terminal télé que via l'application Helix télé. Après avoir utilisé un analyseur de traffic (ntopng) pour voir ce qui ce passait, j'ai remarqué plusieurs alertes sur des packets qui indiquaient que TLS ne semblait pas utilisé. Je me suis alors rappelé qu'il y a une option disponible sur le service "DNS Resolver" de pfSense pour utiliser "DNS over TLS". J'active ça et bingo! Les vignettes s'affichent rapidement dans tous les menus autant que l'application que sur le terminal.

 

Mon routeur était configuré pour utiliser ses propres DNS et non ceux fournis automatiquement par le WAN DHCP de Helix. En l'occurence j'avais dans l'ordre, le DNS public de Google et ensuite, ceux de Videotron. En activant TLS, je peux voir dans les logs que toutes les requêtes DNS envoyée à Google, sont faites sur le port 853 (normal). Une fois la solution établie, j'ai voulu me reconnecter sur Videotron et enlever Google. J'ai donc contacté le support technique pour leur demander si leur DNS supportait TLS ou Https et ils n'ont pas pu me répondre... Ils m'ont dit de le tester pour voir et en effet, Videotron ne supporte apparament pas les requêtes DNS sécurisées. Au final, j'ai donc remis Google et aussi le DNS public de Cloudfare afin d'avoir plus de 2 DNS et tout fonctionne normalement depuis.

 

Je ne peux pas dire que tout est clair pour moi à ce stade. Configuré normalement (pas en bridge), Helix utilise certainement les DNS de Videotron. Comment se fait-il que ce seul changement en mode bridge ait réglé mon problème? Intrigant...

 

Vidéotron: Il serait bien que vous fournissiez plus d'informations concernant vos DNS. Le support répond que l'information n'est pas publique, difficile de travailler avec ça. 

Dernières discussions