Le bon endroit pour vos questions techniques

DVR et SMTP

Répondre
ironfvck
Initié

DVR et SMTP

J'ai un routeur videotron EMG2926 sur une connexion résidentielle. J'ai installé un petit système de cameraa chez moi avec un système ayant quelques année (DVR Bunker Hill Security #61229). Mon DVR se connecte bien sur le réseau en IP statique que je lui attribue, et le flux video passe par le port (que j'attribue également moi même) 3001).

À l'interne, tout est beau. Si mon cellulaire est connecté sur le réseau local, je peux me connecter et avoir accès au flux vidéo via l'adresse locale en 192.168.x.x.

 

Cependant, depuis l'extérieur du réseau, je ne suis pas capable de m'y connecter. Je suspecte un problème de port entrant ou sortant bloqué. (la seule solution broche à foin que j'Ai trouvé et d'accéder au flux video avec un ordi sur le réseau local, puis d'accéder à cet ordinateur à distance via les fonctionnalité de bureau à distance de windows, mais c'Est vraiment pas l'idéal)

 

De plus, le système de caméra peut envoyer des alertes par courriel. J'ai tout paramétrer comme il faut, avec le serveur smtp de gmail et le port correspondant (j'ai essayé 465 et 587). Mais là encore, ça ne fonctionne pas, le DVR n'arrive pas a s'authentifier (et donc à envoyer une alerte courriel). Là encore, je suspecte un problème de port entrant/sortant.

 

Je suis ouvert à toute suggestion pour essayer de faire fonctionner ça...

6 RÉPONSES 6
BrunoLavoie
Initié

Pour ton accès a distance assure toi que ton port est ouvert. Fait une recherche sur open port checker dans Google et test le port 3001. Si ça indique qu'il est fermé, la config sur ton DVR ou ton routeur n'est pas bonne.

Pour le smtp, il faudra que tu actives le "Less secure apps" sur ton compte gmail. Fort probable que le DVR n'est pas capable de s'authentifier correctement sur le serveur de Gmail a cause de ça.
ironfvck
Initié

Pour le smtp, j'ai fait ce test là, ça fonctionne pas plus.

 

Pour ce qui est de l'ouvrerture de port, j'Essaie dans le routeur, mais j'y arrive pas plus. Aussi, faut-il modifier le firewall ? J'ai aucune idée de comment ouvrir les bons ports.

Capture_routeur.png

m1z5mK1

Oui, si tu as un firewall sur le DVR, tu devra ouvrir les ports. Pour ton routeur voici :

Port Range : 3001

Translation port range : 3001

Server IP Address : Custom 

et en dessous l'IP du DVR (192.168.x.x) 

Tu peux échanger le nom en haut a droite pour t'aider à garder l'information de la règle : exemple DVR-3001

Ensuite clique sur Add.

Pour revenir sur le gmail. Lorsque tu as activé  le "Less secure app" , quand il essaie d'envoyer un email, ça va t'envoyer des demandes dans le courriel que c'est vraiment toi et d'accepter aussi. Il faut utiliser SMTP.gmail.com port 587 avec Use TLS  et authentication . 

ironfvck
Initié

Bon, j'ai donc fait des tests.

J'ai paramétré le routeur videotron comme indiqué pour ouvrir le port 3001. Mon interrogation par rapport à un firewall était plus au niveau d'un firewall sur le routeur, mais visiblement j'ai quand même réussi à ouvrir le 3001 (on va prendre cette victoire). Cependant, bien que le port soit ouvert, je n'arrive visiblement pas a m'y connecter depuis l'extérieur, mais j'Essaie aussi d'être en contact avec le fabriquant pour aider de ce bord là.

port_3001_open.png

Ensuite, je suis allé dans le paramétrage du DVR en lui même. Visiblement, que je sois en Static IP ou DHCP, je n'arrive pas a m'y connecter de l'extérieur.

 

SMTP sur 587 avec SSL activéSMTP sur 587 avec SSL activé

Restant brave, j'ai essayé d'aborder le problème du smtp. J'ai fait les manips tels qu'indiqué, et même testé d'autre paramètres. Dans l'interface je peux choisir SSL actif ou non.

Message d'erreurMessage d'erreur

En non-actif, je reçois une "unknow error", en actif, je reçois une "authentification failed".

Configuration DHCPConfiguration DHCP

Pour information, la configuration réseau (DHCP ou static) permet une option "Auto port forwarding" par défaut sur "enable".

 

Quoique je fasse, quelque soit ma configuration, tout en ayant pris soin d'activer les "less secure apps" dans le gmail, je ne reçoit aucune alerte dans mon compte gmail (donc comme si le DVR n'arrivais jamais a sortir du réseau, et donc n'atteint jamais véritablement gmail).

 

Je sais que ça dépasse ici probablement les problématiques liées directement au routeur de Videotron, mais je m'essaie pareil, peut être que quelqu'un va avoir un éclair de génie que je n'ai pas eu...

 

Dernières discussions