Le bon endroit pour vos questions techniques

Site "Mon dossier" de l'ARC injoignable

Répondre
Initié

Site "Mon dossier" de l'ARC injoignable

Bonjour! 

 
Je viens de migrer sur le nouveau services internet Helix et j’aimerais savoir s’il y a une différence au niveau filtrage réseau (antiddos ou autres!) entre l’ancien service et Helix ? 
 
Depuis la migration, le site “mon dossier” de l’agence du revenu du Canada ne fonctionne plus. 
 
Comme test, je vais sur: "https://www.canada.ca/fr/agence-revenu/services/services-electroniques/services-electroniques-partic... et je clique sur “Ouvrir une session à l’ARC” et j’obtient l’erreur: “Safari can’t establish a secure connection to the server “apps…”
 
J’ai pris une capture de paquets sur le port ethernet du modem de mon routeur au moment ou je clique sur le lien “Ouvrir une session à l’ARC” et je vois ce type paquets partir:
88 21.991769 74.59.48.32 198.103.206.26 TLSv1.2 192 Client Key Exchange, Change Cipher Spec, Encrypted Handshake Message
Ou
22 0.091564 74.59.48.32 198.103.206.32 TLSv1.2 1417 Application Data
 
Malheureusement, il ne se rend pas à destination car ensuite il y a du TCP Retransmission:
89 22.106956 74.59.XX.XX 198.103.206.26 TCP 192 [TCP Retransmission] 56815 → 443 [PSH, ACK] Seq=518 Ack=4644 Win=65535 Len=126 TSval=118149164 TSecr=3715944872
Ou
23 0.173203 74.59.48.32 198.103.206.32 TCP 1417 [TCP Retransmission] 56808 → 443 [PSH, ACK] Seq=644 Ack=4695 Win=65535 Len=1351 TSval=118127307 TSecr=3715922983
 
Jusqu’à ce que la session TCP “close”.  
 
Du coup, la question est: Pourquoi ce paquet n’est pas transmit? Clairement, mon routeur envoie le paquet à la passerelle de videotron. C’est toujours à la négociation SSL que ça semble problématique. 
 
Info supplémentaire:
  • Comme vous pouvez le comprendre, je n’utilise pas le routeur d’Helix, seulement en mode bridge.
  • Tout les appareils derrière le routeur ne joint pas le site de l’ARC mon dossier
  • J’ai testé de passer par mon téléphone en LTE, j’ai aucun soucis. Je peux joindre le site de l'ARC sans problème.
  • J’ai pris mon routeur et j’ai remplacé mon modem Helix pour mettre un modem LTE (qui fournit un adresse DHCP, question de tester le routeur) et le site de l’ARC fonctionne bien.
  • Avant le changement de services, j’y accédais sans soucis. C’étais le même routeur, même config.
 
J’ose même pas appeller le support pour ce genre de soucis, je sens que ça va être “mon problème” 🙂
 
On a pas un network admin qui lit ce forum et qui sniff du paquets pour debug? 🙂
 
Si non, pas grave, je ferai mes transaction à l'ARC via LTE! 
 
Merci!
 

 

14 RÉPONSES 14

Je suis en mode bridge et ca change rien.

Initié

Des amis a moi ont fait des tests:

 

Ca semble affecter macos et linux sous le modem technicolor. 

 

J'ai cette version: CGM4140COM_3.12p12s1_PROD_sey

 

Videotron a le control sur la version du routeur je crois, je ne trouve aucune manière de mettre à jours le routeur.

 

Je sais pas si le modem fait du packet IDS mais c'est vraiment problèmatique. 

Super utilisateur

La borne Helix n'est pas la source du problème.  Certains abonnés Videotron avec le routeur ZyXel ont le problème. 

 

Un de mes amis est avec Cogeco et il a le problème.

 

Je suspecte que le trouble est du côté du site de l'ARC.

Sans diagnostique de la part de videotron ou ARC, on ne sais pas sur quel côté les packets sont perdu et donc qui est la faute. C'est malheureux en cette période d'impôt.  

 

Je vais chercher de l'aide sur le support de peering, j'ai du peering avec eux à mon travail. On verra si je me fait plus d'amis labas 🙂 

 

Merci pour ceux qui ont répondu pour confirmer un problème général vers l'ARC. 

J'ai analysé les paquets d'un windows et un macos, la différence est l'option tcp timestamp activé sous un système unix.

 

Sous linux:

sysctl -w net.ipv4.tcp_timestamps=0 

 

Fix le problème de communication.

 

Ça pointe de plus en plus vers l'antiddos de l'agence du revenu...

 

Malheureusement, sous Catalina MacOSX, il n'est plus possible de désactivé le tcp timestamp. Windows 10 ne l'active pas par défault. 

 

Si ça peut aider les gens sous linux 🙂 

 

Peace!

 

Dernières discussions